Cydia iOS10 插件 Cydia iOS11 插件

iOS 越獄插件支援查詢工具「 TweakCompatible」

每當有新版本越獄推出後,我們無法確認的是要如何知道插件是否還能夠在新版系統上順利執行?過去通常都是靠網友共同測試回報做成 Google 試算表來查詢,但試算表方法對於手機版不易於查詢,不過好在有位熱心開發者替我們推出了一款能回報插件支援度的插件 TweakCompatible ,並且可配合網頁查詢插件支援情形,如此一來,就不用這麼驚心膽跳會裝到不相容的插件。

 

TweakCompatible上所顯示的支援資料,並不是作者獨自一人測試而來,而是由全世界用戶回報而來的,當越多人回報時,相對插件支援訊息就會越豐富。

 

查詢插件支援狀態:透過插件

▼ 安裝完TweakCompatible插件後,就可發現每個介紹頁面最底下會出現三個按鈕選項,如想要查詢這款插件是否能支援當前iOS版本,可點擊「Info」後,會顯示右側支援結果,可看出 XBarRemover 是能夠在 iOS 11.1.2 上支援。

 

 

查詢插件支援狀態:透過網頁

步驟 1. ▼ 除了透過插件外,當然也可以透過 TweakCompatible 網頁版本來查詢,透過瀏覽器登入後,可直接透過Search 輸入想要查詢插件名稱,選擇好設備iOS版本就可查詢,另外也可以直接透過 Filter 篩選支援清單。

步驟 2. ▼ 範例為搜尋 Activator 手勢是否支援 iOS 11.1.2 ,結果顯示 v1.9.13~beta 1 是完全無法工作。

步驟 3. ▼ 最新v0.0.8版本開始,功能再次升級,改為插件圖按下和右側都會會直接顯示支援狀態,綠色勾勾表示當前設備和iOS版本能支援,橘色時鐘表示部分功能或版本會有無法支援Bug問題,紅色大叉表示完全無法支援。

TweakCompatible 網頁版網址:https://jlippold.github.io/tweakCompatible

 

回報插件支援狀態

假如,我們發現某些插件在目前設備上,是可以順利執行或是無法執行,甚至會有Bug問題,那可以直接透過 TweakCompatible 功能來進行回報,不過必須先申請Github帳號才可以使用回報功能。

步驟 1. ▼ 開啟插件介紹頁面,下方會有 WorksBroken 按鈕,這兩個按鈕分別是支援不支援。假如我們安裝完插件後,發現這款插件能正常執行,那可以點選「Works」,會轉跳至回報頁面上,會出現三條選項,中文功能說明如下,選擇完成後點擊「Next」繼續。

  • Tweak is working on iOS 11.1.2 :插件可以正常在 iOS 11.1.2 執行
  • Tweak is partially working on iOS 11.1.2:插件部分能正常在 iOS 11.1.2 工作
  • Tweak is not working on iOS 11.1.2 :插件不能夠正常在 iOS 11.1.2 執行

 

步驟 2. ▼ 此時會需要登入 GitHub 帳號,登入完成後,會自動帶出插件、系統相關資訊,點下「Submit new issue」來回報。

步驟 3. ▼ 最後別急著點下「Comment」按鈕,否則會卡在這頁面,請在 Leave a comment 內附加上點說明,像是work之類,最後才可點擊「Comment」完成回報。

除此之外,另還有一款「一秒了解iOS插件支援情況,透過這款工具Compatimark就能偵測」插件,也值得安裝。

前提條件

  • 僅支援 iOS 10~11.3.1 越獄用戶,如沒有越獄請參考這篇iOS JB教學與技巧
  • 想裝最新版本需另外加入作者軟體源「http://repo.jed.bz

 

透過軟體源安裝教學

步驟 1

▼ Cydia 搜尋「tweakCompatible」,將它安裝起來,如果找不到插件請參考這篇。(作者:treAson,軟體源:BigBoss)

步驟 2

點選「確認」安裝,安裝完畢再點下「重新啟動SpringBoard」。

 

延伸閱讀

▼ 如果覺得本篇教學不錯,歡迎加入瘋先生粉絲團追最新教學技巧 ▼